Mozilla Firefox making great progress with add-on compatibility #fx7 #Aurora

Up to the release of Firefox 4, my browser of choice’s add-on compatibility record was awful. The surest way to break an add-on was to update the browser to a higher version number. Since Mozilla have moved to an accelerated release schedule, they issued a call to devs regarding the compatibility issue, and it appears their efforts are meeting with success.

I’m running version 7.0a2 (the Aurora channel), and all 14 of my add-ons work. All but one are officially compatible, and that one functions perfectly. See for yourself:


In other news, there really is NO reason whatsoever to be running the release version of Firefox. Switch to the Aurora channel: it’s just as stable – if not more so – than release, has much better performance and unlike Chrome’s Dev channel features aren’t routinely broken overnight.

Author: jdrch

ISTJ, Rice Owl, UF Gator, mechanical engineer. STEM, sports, music, movies, humor. Account mine only & unaffiliated.


Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s