How to fix the “Failed to get all licenses needed for this job” error in CD-adapco STAR-CCM+


This troubleshooting post assumes the following:

  • You’re on Windows (8.1+ Pro 64-bit).
  • You’re using STAR-CCM+ 8.06+.
  • STAR-CCM+ is using a locally stored license.dat file.
  • STAR-CCM+ and FlexLM were installed using default settings for file paths, ports, etc.
  • The CDLMD_LICENSE_FILE Environment Variable points to 1999@YourPCHostname.
  • The CD-adapco_License_server service is running.

but you’re still getting the error:

“Failed to get all licenses needed for this job. Asked for 1 licenses of ccmpsuite”

when trying to start a new simulation.

The “ccmpsuite” part of the error message is important, because it tells you the type of license you requested but failed to get. Ergo, you’ll need to take a look at your license file to see what kind of license you have in the first place.

  1. Open C:\Users\YourUsername\license.dat in any text editor.
  2. CTRL + F the file for “ccmp.” More than likely you’ll find the only result is a reference to “ccmppower” and not “ccmpsuite.” This means you have a Power Session license.
  3. Return to STAR-CCM+ and open the new simulation menu again.
  4. Under License, check Power Session as shown below:
  5. Click OK. You should be greeted with a successful new simulation creation output:

    New simulation success!
    New simulation success!

Author: jdrch

ISTJ, Rice Owl, UF Gator, mechanical engineer. STEM, sports, music, movies, humor. Account mine only & unaffiliated.

1 thought on “How to fix the “Failed to get all licenses needed for this job” error in CD-adapco STAR-CCM+”


Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s